Railsでexecjs for a list of available runtimesのエラー

Dec 3, 2014
AD:

Vagrantで空のUbuntuを作って、Railsを立ち上げようと思ったら、下記のエラーがでました。

単純にexecjsはnodejsが必要なので、nodejsを入れて解決です。

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 0 | Total: 0 | Feedly: 0

HerokuのPostgresにローカルのpgAdminなので直接アクセス

Nov 30, 2014
AD:

HerokuのPostgresにローカルのpgAdminなどで直接アクセスしたい場合

Screen Shot 2014-11-30 at 9.03.52 am

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 0 | Total: 0 | Feedly: 0

Ruby 1.9.3 gem pg error in Ubuntu

Nov 21, 2014
AD:

環境

VagrantでUbuntu14.04
rbenvを使ってRuby 1.9.3-p551
gem pg
で下記のエラーがでました。

解決

libpq-dev(UbuntuのPostgres系パッケージ)が入っていないが原因ですよねー

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 0 | Total: 0 | Feedly: 0

Herokuとローカルでgemのgit指定方法でエラーのメモ

Aug 11, 2014
AD:

Gemの指定

ローカルのGem

HerokuのGem

もしローカルで、Herokuの指定方法だと、下記の用にcloneエラーがでてしまいます。

地味に悩んだのですが、 git://をhttpsに変換するように、configに追加するようにして、herokuと同じ指定方法で動くようになりました。

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 0 | Total: 0 | Feedly: 0

nokogiri (1.5.2)が入らない!!件

Feb 27, 2014
AD:

Rails3.1の古い案件の修正が入ったので、環境を構築していたのですが、Nokogiriが1.5.2を入れないと動かない構成でして、苦労しましたのでメモしておきます。

エラー内容

解決方法

NokogiriとUbuntuで下記のもので入るようになるとはあるのですが、1.5.2はこれでもうまく行かず。。

下記のオプションをつけてなんとかインストールできました。

参考サイト

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 1 | Total: 1 | Feedly: 0

Herokuのrake db:migrateでエラー

Sep 14, 2013
AD:

Herokuにて、Deploy後に、rake migrateするとエラーで進めなかったのでメモしておきます。

状況

解決するまでにやったこと

Heroku Postgresを使用しているんですが、作成したものを一度削除し、再度作成しなおしました。
この時点で、エラー内容が変わりました。

configで確認するとDATABASE_URLするとHEROKU_POSTGRESQL_カラー_URLが違っていました。

この時点では、結局同じエラー”`[]’ for nil:NilClass”になりました。

最後にheroku restartしてPostgreSQLもrestartして接続ができるようになりましたー
でも、どうして、起きたのかはイマイチ不明。。。。

ほかにもいろいろとPaaSのサービスを使用しているんですが、こういう時にBlackBox化するので、やっかいですねー
ちなみに、ログはpapertrailを使用しているんですが、今回の状況だとログをみても原因が追求できませんでした。

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 1 | Total: 1 | Feedly: 0

Rails 4.0.0 & Ruby 2.0.0でdebuggerでReadlineのエラー

Aug 9, 2013
AD:

rails

せっかく新しい案件が来たので、Ruby2 & Rails4で開発しているんですが、debuggerでReadlineのエラーがでたので、メモしておきます。

まず環境

  • Vagrantのubuntu12.10.64bit
  • rbenv – Ruby 2.0.0p247
  • rbenv – Rails 4.0.0

エラー内容

エラーを読みかぎりReadlineがないらしいので、Readlineをインストール

Readlineを指定して、rbenvでRubyを入れなおし

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 0 | Total: 0 | Feedly: 0

Ruby 1.9.3 rails console error by “completion.rb:9:in `require'”

Feb 7, 2013
AD:

I set up Rails Env with ruby 1.9.3p374 & Rails 3.2.11
I tried to use consolce and I got this massage…

Error

Add re-readline

Done

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 1 | Total: 1 | Feedly: 0

Railsでサイト名などを設定する場合

Feb 6, 2013
AD:

設定方法

参照方法

Done

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 0 | Total: 0 | Feedly: 0

Country Code for Rails with Migration

Feb 6, 2013
AD:

I want to setup contry code for my Rails app so I searched by google there are some Gem but I just want to make Tables & Model.
I used data from here

Make migratiton file

Add SQL from here

and then

Done.

Twitter: 0 | Facebook: 0 | Google Plus: 0 | Hatena: 0 | Pocket: 0 | Total: 0 | Feedly: 0

ARCHIVES