WordPress 3.*から4.*にアップグレードしたら管理画面でload-scripts.phpがエラーになる件

Jul 14, 2015
AD:

管理しているWordpressのバージョンを3.*から4.*に上げたところ、投稿のページでtinymceが表示されなくなりました。
問題はload-scripts.phpの吐き出すjsがどういう訳か途中でレンダリングが止まっているようでした。
Googleさんで調べてみたら、使用しているプラグインを無効やThemeを変更すると直るとか、Wordpressのファイルをすべて上げ直すなどありましたが、どれもうまくいきませんでした。
Screen Shot 2015-07-14 at 11.13.08 am

対処方法

CONCATENATE_SCRIPTSをfalseをwp-config.phpを追加したらレンダリングエラーはなくなりました。
ちなみに、CONCATENATE_SCRIPTSをコード読んで観る限りだと、js&cssの圧縮を無効にするようですので、パフォーマンスに影響はあるかもしれませんね。。。

4.*の不具合かもしれませんね。
https://wordpress.org/tags/concatenate_scripts

Related posts

AD:

One Comment, Comment or Ping

Reply to “WordPress 3.*から4.*にアップグレードしたら管理画面でload-scripts.phpがエラーになる件”

ARCHIVES