php4でもjson_decodeを使いたい

Aug 6, 2012
AD:

クライアントさんのサーバの未だにphp4のものがあり、APIを作成したのに、jsonが使えなくて大変だったので、メモしておきます。

状況

PHP Version 4.3.9
サーバはごく普通のホスティングレンタルなので、PHPのVersion等を上げることは不可能

対応

調べるとふた通り対応方法を発見。
upgradephpという、php5関係に追加された関数をphp4でも使えるようにするライブラリを発見。
はじめはこれで試してみるが、日本語が文字化けたので諦める。

次に、PearのJsonパッケージを使用。
しかし、サーバにPearをインストールすることはできないので、ファイルをDLしてきて対応しました。
上記のリンク先のLinksからファイルをDLして、解凍するとその中に、JSON,phpがあります。
あとは、こんな感じで使用します。

注意

$convert_dataは、配列でなくオブジェクトのデータになっているので注意してください。

Related posts

AD:

No Comments, Comment or Ping

Reply to “php4でもjson_decodeを使いたい”

ARCHIVES